/ Tech News

Enlarge / The Handmaid’s Tale, a Hulu original series. The long, give-and-take saga of 4K streaming on Hulu continues with the addition of 4K streaming for supported Roku devices. Hulu also added 5.1 surround sound capabilities on Roku. The Disney-owned streaming platform updated its user-facing help pages with the information sometime in the past few …

/ Windows Linux PC Software

About a year ago we reviewed the Razer Huntsman Elite, arguably the first mainstream foray into optical keyboard switches. And uh…the only one, really. Optical switches still haven’t made much headway against traditional mechanical keyboards. Mentioned in this article Razer is doubling down though, introducing the Huntsman Tournament Edition for 2019. Like the rest of Razer’s …

/ Apple Mac News

Following the App Store’s debut in 2008, a cottage industry for third-party iPhone camera apps began to flourish, a testament to how underwhelming Apple’s software was at the time. Over time, Apple started catching up, with the latest iOS releases proving the company now takes the Camera app as seriously as the hardware that drives …

/ Tech News

iRobot Ars Holiday 2019 View more stories We could all use a little more help around our home, and luckily now there’s a lot of tech that can lend a hand. So that’s where we’re looking for our latest holiday gift guide. There are a plethora of smart home devices that can do everything from …

/ Apple Mac News

They sound pretty good. They have active noise reduction. They let you summon a digital assistant hands-free. They are relatively comfortable and not too big. And the Echo Buds true wireless earbuds from Amazon only cost $129. What’s the catch? The catch, besides an obvious and expected bent toward Alexa and Amazon services, is that …

/ Security News /

A team of cybersecurity researchers has disclosed a new severe vulnerability affecting most Linux and Unix-like operating systems, including FreeBSD, OpenBSD, macOS, iOS, and Android, that could allow remote ‘network adjacent attackers’ to spy on and tamper with encrypted VPN connections. The vulnerability, tracked as CVE-2019-14899, resides in the networking stacks of various operating systems …